[VTA] VTA on ZCU102

Hello all,

I’m interested in getting VTA running on the ZCU102. I’ve heard rumblings that it is being worked on, are there any details on the progress?

What needs to be done for a port? I would be happy to lend a hand. :slight_smile: (I have a PYNQ image built for the ZCU102 already).

Hi, I’m glad you have successfully built an image. I’ll prepare a PR to provide support on the ZCU102 next week,

I’ll notify you when it’s ready.

Thierry

That’s nice to hear, I look forward to it!

Peter

@thierry

Any update on the PR? I am also interested on this. I am at the same stage at @feralwitchchild with a Pynq running on my zcu102.

FYI I used this guide to build the Pynq image. It is in Japanese but google translating is enough to understand. I Built against 2018.3 and worked the same.

https://qiita.com/jin0g/items/42d53fd1eca42ec17c0f

Regards

ZCU102 support is still WIP; I’ll update the thread when it’s ready.

1 Like

Can You guys help me in building the PYNQ Image for my ZCU102 board.

@feralwitchchild

I’m interested in building pynq image for zcu102 . can you help with providing any source document.

also let me know if vta is available for zcu102 board

Hi, @imharish63 are you looking at using it for TVM??

Hi @eamicheal

yes i am looking for using TVM on it

Hi @imharish63, I’m not sure if TVM supports or works on ZCU102, I tried this a few months ago with no success, I tried running deploy classification but it got stuck at load.module anytime I tried it. I can share with you the image for v2.6 and we can synergize to see if we can get it working

HI @eamicheal, I tried to build pynq image for zcu102 but the bitstream was not loading for me the light is always red. some boot partition error after successful pynq image generation. So i asked my mentor to provide me zcu104 and i got it. But it would be helpful if you can share the procedure to build pynq image for ZCU102. Also let me know the errors you encountered here. If I have solved any such i could help. for info I am currently working on zcu104. I have seen lot of errors of similar kind.

Kind Regards,

Hi @imharish63

from my earlier post, everything got stuck at the load_module stage, I am not sure why it doesn’t progress from that stage,… any idea? For the ZCU104 which tvm commit or version are you currently using? FOr ZCU102 image creation, find my custom GUIDE_HERE

@eamicheal

In that case , I am using tvm version 0.8.0. I am not sure which commit.

Kind regards, Harish

@eamicheal I am busy with some other work. So i am not finding time to generate image for zcu102. Once I find time i will try.

Kind regards, Harish