[VTA} Error when running autotune tutorial

Hello,

I’m trying to run the autotune tutorial for autotuning CNNs to run on VTA.

I get the following error:

Traceback (most recent call last):
  File "autotune.py", line 252, in <module>
    tune_and_evaluate(tuning_option)
  File "autotune.py", line 180, in tune_and_evaluate
    vta.reconfig_runtime(remote)
  File "/home/youn/tvm/vta/python/vta/rpc_client.py", line 32, in reconfig_runtime
    freconfig = remote.get_function("tvm.contrib.vta.reconfig_runtime")
  File "/home/youn/.local/lib/python3.6/site-packages/tvm-0.6.dev0-py3.6-linux-x86_64.egg/tvm/rpc/client.py", line 57, in get_function
    return self._sess.get_function(name)
  File "/home/youn/.local/lib/python3.6/site-packages/tvm-0.6.dev0-py3.6-linux-x86_64.egg/tvm/_ffi/function.py", line 131, in get_function
    "Module has no function '%s'" %  name)
AttributeError: Module has no function 'tvm.contrib.vta.reconfig_runtime'

I’m not really sure what’s wrong. Any help would be appreciated. Thanks!

have you solved the problem?

In order to run the AutoTuning tutorial on VTA you need to run the device tracker on a host machine, and register the device to the tracker by running tvm/apps/vta_rpc/start_rpc_server_to_tracker.py (you’ll need to modify fleet:9190 with <tracker_host_name>:<tracker_port>

1 Like

Hi @youn123

Please refer to this two section Start RPC Tracker and Register devices to RPC Tracker

Hope helps,

Does the replies solve your problem? It doesn’t on mine…

python -m tvm.exec.query_rpc_tracker --host=0.0.0.0 --port=9190 –>

key | total | free | pending

pynq | 1 | | | 1 | | | | | 0

Doesnt this mean the RPC tracker is started?

++ I refered to those two sections above which is on tutorial, but it wont work on firstplace.

Is this not what the tutorial says? I have the same issue still…

1 Like

Does anyone have any advice for this?

I managed to run with the provided scrip: start_rpc_server_to_tracer.py. It should be because of pythonpath setting.

3 Likes

Thank you so much for the clear comment.

It totally works on your advise !!

I am getting the same issue. How did you solve it. Your help would be appreciated! I have tried but nothing seem to work.

Thanks.

@rsahu

You can run this script like this.

cd $TVM_HOME
pushd apps/vta_rpc
sudo -E ./start_rpc_server_to_tracker.sh
popd

Note that the script expects to be run the exact folder, that’s why pushd/popd.

Update the ‘flee’ with your host ip/name Also ensure to set the variable for

  • VTA_HW_PATH