We currently have two families of “Runtime” in TVM:
- c and c++ runtime – describes the implementation of
- graph, vm, aot runtime – implements Module-Based Model Runtime API (eventually…), which drives model-level execution by invoking a series of operator functions and handling control flow.
Let us rename GraphRuntime, VirtualMachine runtime, and AOT Runtime to something else. It’s too confusing to have the word “runtime” everywhere and not everything is a runtime . Here are some options:
O1. GraphExecutor, VirtualMachine executor, AOTExecutor
O2. GraphDriver, VirtualMachine driver, AOTDriver
O3. GraphEvaluator, VirtualMachine evaluator, AOTEvaluator
I propose O1. O2 makes sense for GraphDriver but not so much the rest. O3 is overloaded for VirtualMachine (“evaluator” is ambiguous").
Thoughts/opinions/additional name proposals?