[RFC] Rename gpu to cuda

This RFC proposes to rename gpu to cuda. Two main reasons for this renaming:

  1. There are now more kinds of GPUs, e.g., AMD Radeon GPUs and Qualcomm Adreno GPUs.
  2. Mainstream frameworks like PyTorch clearly indicate CUDA device, e.g., PyTorch uses torch.cuda to support CUDA tensor types, so this renaming will make it more consistent with the other frameworks.

We have a related RFC for DLPack. Look forward to hearing your thoughts!

cc @tqchen @junrushao1994


I’m in support of this change, especially as it would clean up some places where there is ambiguity as to whether “gpu” and “cuda” are synonymous in the code. For example, tvm.device('gpu') and tvm.device('cuda') will both return a cuda device, but tvm.testing.requires_gpu and tvm.testing.requires_cuda have separate requirements. Distinguishing between the physical gpu and the software cuda/opencl/vulkan runtimes would remove this ambiguity.

1 Like

I support this! It does seem ambiguous.

Thanks @yuchenj , this is a great idea