In the unified IR proposal. We plan to seprate the low-level IR(named tir thanks to everyone’s suggestion) from the tensor expression DSL(compute and schedule).
The tensor expression DSL served as a middle layer for bridging high-level and low-level IRs. Specifically, the compute, scan, placeholder and scan are concise dataflow descriptions that allows us to quickly construct functions that can be lowered to low-level IRs.
So far we took the strawman in the original namespace proposal(though we don’t feel attached to the name). Given that we have not yet make changes to the python side(which will affect user API), it would be great to hear from everyone’s thoughts before doing so.
Once we decided on the namespace, we will update the the c++ code as well as python side in the incoming refactor. Here is an example code under the new namespace
from tvm import tdsl_name
x = tdsl_name.compute(...)
Here are some candidates. Please share your thoughts, and suggest new names.
- top(tensor operation language): current strawman
- te(tensor expression language): I know we don’t like the name for tir, what about this time:)
- tel(same as above, with the additional l)
- tensorcl
0 voters