Meet an error when deploy nms on target

I can deploy a nms function on host, but when I deployed the function on target, I got this error, I tried cpp and python ways: terminate called after throwing an instance of ‘dmlc::Error’ what(): [07:46:59] /home/root/tvm/src/runtime/ Check failed: ret == 0 (-1 vs. 0) : TVMError: Check failed: f != nullptr: Cannot find function tvm.contrib.sort.argsort_nms in the imported modules or global registry Stack trace: File “/home/root/tvm/src/runtime/”, line 123 [bt] (0) lib/cpp_deploy_normal(dmlc::LogMessageFatal::~LogMessageFatal()+0x38) [0x55825c5838] [bt] (1) …/…/build/<char, std::char_traits, std::allocator > const&)+0x30c) [0x7fa2078a64] [bt] (2) …/…/build/ [0x7fa2054e50] [bt] (3) lib/cpp_deploy_normal(+0xa254) [0x55825c9254] [bt] (4) lib/cpp_deploy_normal(+0x9a90) [0x55825c8a90] [bt] (5) …/…/build/ [0x7fa2070930] [bt] (6) lib/cpp_deploy_normal(+0x3738) [0x55825c2738] [bt] (7) lib/cpp_deploy_normal(+0x2e24) [0x55825c1e24] [bt] (8) /lib/ [0x7fa1c20ce4]

Stack trace: [bt] (0) …/…/build/ [0x7fa2070d60] [bt] (1) lib/cpp_deploy_normal(+0x3738) [0x55825c2738] [bt] (2) lib/cpp_deploy_normal(+0x2e24) [0x55825c1e24] [bt] (3) /lib/ [0x7fa1c20ce4] [bt] (4) lib/cpp_deploy_normal(+0x3000) [0x55825c2000] line 29: 7731 Aborted lib/cpp_deploy_normal

1 Like

I think I solved this problem on vta target. It is a simple pass bug causing extern function ‘sort’ error.

I met the same issue. I read through the post by @hht, who had a preliminary solution to solve it in runtime. I wonder is there any pointer to solve this issue in compile time?

May be related! Issue