How to use Vitis-AI Integration for Ultra96 v2 board?

Hi, I tried the pyxir/examples/tvm/, which shows at the tvm doc, and I almost succeeded. But when I ran the program on the ultra96 board, I got the error.

I checked the dpu version on the host and the board, I found they were both v1.4.1.

I think my situation is really like this issue, but I don’t know how to fix it. I know using the vai_c_ to compile the model needs an ‘arch.json’, I guess lacking the file for ultra96 may cause the isssue, but I don’t know how tvm uses it.

By the way, I didn’t use the PYNQ2.6-Z2 image for ultra96v2, which the tvm doc says, I used PYNQ2.6-Ultra96V2, I think they were different boards, and I didn’t boot successfully using the PYNQ2.6-Z2 image when I try.

I would appreciate it very much, if you can help me set up the flow for ultra96 v2 board. I think the doc is not very clear, and maybe it has some inconsistence with the version type among the vitis-ai.

You may check this for the details, because I can’t put many links and images here as a new user.