Failure [INSTALL_FAILED_OLDER_SDK]

Hi @ tkat0,

I am working on the Deploy the Pretrained Model on Android example. Where I am facing below error while installing APK on to the my android phone. Could you please help me to understand this issue? What am I missing there?

Error:

$ ./adb install -t ~/Software/tvm_org/RajuKoppada/android_tvm/tvm/apps/android_rpc/app/build/outputs/apk/release/tvmrpc-release.apk Performing Push Install /home/kvraju/Software/tvm_org/RajuKoppada/android_tvm/tvm/apps/androi…se.apk: 1 file pushed, 0 skipped. 13.2 MB/s (3940804 bytes in 0.285s) ** pkg: /data/local/tmp/tvmrpc-release.apk** Failure [INSTALL_FAILED_OLDER_SDK]

My phone OS details:

Android Version : 6.0.1 Model : One + X

Adb version:

./adb --version Android Debug Bridge version 1.0.41 Version 30.0.4-6686687

Note: I didn’t modify anything in the build.gradle

Thanks in advance. Raju

@tkat0,

Further on this issue right, when I run the adb devices query from docker container I didn’t find my phone in the devices list and when I run same adb device query outside the docker container the device list showing my phone. So that I was trying to install tvmrpc-release.apk from outside the docker container I hit with above application install failed error ( Failure [INSTALL_FAILED_OLDER_SDK])

Am I missing anything here? From the container why adb is not able to find my phone in the device list

Thanks and Regards, Raju