Error: VTARuntimeShutdown symbol is undefined

Hi, I tried some tutorials(deploy_detection, deploy_classification, etc) using PYNQ Z1 Board.

However, I got the same problem for all the tutorials I ran, on RPC server.

 File "/home/xilinx/tvm/python/tvm/_ffi/_ctypes/", line 78, in cfun
    rv = local_pyfunc(*pyargs)
  File "/home/xilinx/tvm/vta/python/vta/exec/", line 84, in server_shutdown
  File "/usr/lib/python3.6/ctypes/", line 361, in __getattr__
    func = self.__getitem__(name)
  File "/usr/lib/python3.6/ctypes/", line 366, in __getitem__
    func = self._FuncPtr((name_or_ordinal, self))
AttributeError: /home/xilinx/tvm/vta/python/vta/../../../build/ undefined symbol: VTARuntimeShutdown

I searched this Error and found this error was recently solved on VTA build and execution error with new 3rdparty vta-hw, but still I have the error.

My OS’s PYNQ v2.5, and I use the latest commit of TVM(a072da0588c542757d2815832b7f010f530b2428)

I would really appreciate if someone let me know why the error happened. Is there anyone who solved this error?

Have you confirmed that both TVM installs (on pynq and on your host) are up to date?

Yes, both TVM are the same version(a072da0588c542757d2815832b7f010f530b2428), which is updated May 28, 2020.

Ok, I’ll try to reproduce the tutorial on the latest TVM. Did you get the bug after updating TVM, or did you install from a fresh git clone?

I installed both TVM from a fresh git clone

Thank you for your attention!

I am facing same issue while running vta on de10 nano. Is this bug solved yet or not?

it would be great to add debug statements around the line to see what symbols are exposed. VTARuntimeShutdown is indeed defined in

I’ve encountered the same problem with commit ‘da42924a16c5e688bbb31facb3b17ba066b776df’ (2/2 2021)

Check the build directory, I found a ‘T’ symbol in CMakeFiles/vta.dir/vta/runtime/, but was not appeared within the final

I tried to rerun the link command in CMakeFiles/vta.dir/link.txt, aka

‘/usr/bin/c++ -fPIC -std=c++14 -faligned-new -O2 -Wall -fPIC -shared -Wl,-soname, -o CMakeFiles/vta.dir/vta/runtime/ CMakeFiles/vta.dir/vta/runtime/ CMakeFiles/vta.dir/3rdparty/vta-hw/src/pynq/ -lcma’

This error disappeared.