Cmake C++ standard configuration

I had some issue with make cpptest. Upon investigation, I see that a std=gnu++14 somehow sneaked into the build process, and it came after the std=c++17.

I fixed it by replacing this line with


Was there a particular reason we chose not to do this – note that we are using set(CMAKE_CUDA_STANDARD 17) right after it, and I think this is a much more robust way to enforce project C++ standard than adding a std:c++17 flag, which got overridden in my case.

Otherwise I’d like to send a PR to fix this, to prevent others from running into similar issues in the future.