Can not connect andriod device with RPC

I use this tutorials to deploy model to device. And in tvm application I set “Address:; Port :3939; key:andriod”

but I can not connect andriod device,who can tell me what is wrong?

Do you point real ip address of machine running tracker in the android rpc? Android and machine running tracker should be in the same subnet because phone has to connect to that machine to the port 3939 in your case.

I see I understand you,I run “hostname -I” to get my machine ip andress, it is as your replay, I should run “python3 -m tvm.exec.rpc_tracker --host= --port=9190”.But I tried, it does not work…

My pc uses local area network of school, should my phone also use local area network of school??

Android rpc tries to connect to the machine running tracker (btw in its turn tracker will try to connect to the phone as well during the work). Android RPC has special fields which you have to fill before you switch “Enable RPC” slider. Phone must be able to connect tracker machine. The simplest way - to register computer and phone in the same wifi, figure out the ip address of the machine and point it in the tracker and in android rpc.

Thanks your replay,Iwill try again!