[microtvm] Missing uart.h in ethosu core_platform

I’m trying microtvm cmsisnn.
I installed all dependencies and ran run_demo.sh in dir tvm-v0.10.0/apps/microtvm/cmsisnn.
Then I got error:

Obviously, it can’t find the head files “uart.h” and “uart_stdout.h”.
I just used the command

git clone "https://review.mlplatform.org/ml/ethos-u/ethos-u-core-driver"

which shown in tvm-v0.10.0/docker/install/ubuntu_install_ethosu_driver_stack.sh
to download the package. But there is no file called “uart.h” in the following directory, why?

Hi @denis, which version of the driver stack are you using when you checkout the ethos-u-core-driver repository? The version of the driver stack you checkout should match the version mentioned in ubuntu_install_ethosu_driver_stack.sh (currently v21.11)

Hi @lhutton1 Tahnks!
I ran command:

git clone --branch 21.11 https://review.mlplatform.org/ml/ethos-u/ethos-u-core-driver core_driver
git clone --branch 21.11 https://review.mlplatform.org/ml/ethos-u/ethos-u-core-platform core_platform  

Then I got the uart.h ,

And I ran run_demo.sh in dir tvm-v0.10.0/apps/microtvm/cmsisnn, the executeable file demo was successfully generated.

But there is something wrong with arm FVP simulation environment, it failed to allocate stack memory ,

Did you meet this problem before?